SPORTS

MSD Blaster Fl for Yamaha YFZ2450
PN 4247

Note: The MSD Blaster Enhancer is designed for the Yamaha YFZ450 with electronic fuel injectin.

Parts Included:
1 - Blaster FI Controller 1 - MSDView CD 1 - Micro-USB Cable 1 - Mounting Bracket

WARNING: When installing the Blaster FI, disconnect the battery cables. When disconnecting,
always remove the negative cable first and re-install it last.

WARNING: The Blaster Fl Controller is a performance device that allows the vehicle or engine to operate
at increased power and speed. Follow all OEM safety recommendations and use extra

care when operating at increased power and speed.

CAUTION: The Blaster FI Controller will raise the maximum rev/speed limit of the engine. Note
that factory components may not be designed for the increase in rpm and may require
modifications to achieve the best performance and durability.

Note: Do not plug the MSD into PC until the MSDView
Software has been installed first.

INSTALLATION

1. Remove seat by pulling seat lock lever upward and
pull the seat up at the rear.

2. Remove the air box case cover. Note: Do not
remove the air filter. Never operate the engine
without the air filter. Engine damage can occur.

3. Remove the rear fender by unbolting the four bolts
and clips on the fender.

BRACKET INSTALLATION

1. Pull tail/brake light cover down and unhook it from
the back end (Figure 1).

2. Locate the OEM ECU at the rear of the ATV and
disconnect the 34-pin connector.

3. Separate ECU connector pigtail from the rest of
the bundle so it can be pulled approximately 4-5
inches back. Route it into the ATV frame to reach
inside the air box.

4. Slide bracket wings under the fender tabs. Adhere
the supplied Velcro to the grooves on the bracket.
(Figure 2).

e ool
Figure 2 Hook Bracket and Velcro Install.
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2 INSTALLATION INSTRUCTIONS

MSD INSTALLATION

1. Mount the MSD PN 4247 onto the bracket.

2. Connect the OEM 34-pin connector to the MSD.
Route the MSD harness to the OEM ECU (Figure 3).

3. Reinstall the tail/brake light cover and the rear
fender. Note: The air box cover will no longer fit
with the install of the MSD.

MSDVIEW SOFTWARE INSTALLATION
Minimum requirements to install and run the MSDView
software:

* Microsoft Windows XP/Vista/7

* Keyboard and Mouse or some other compatible
pointing device.

Available USB port.

.NET 2.0 or wide band internet access forthe .NET
2.0 installation.

bl e ) >

Figure 3 Connect MSD Inline.

Important: Exit all programs before installing the
MSDView software. I p

TO FACTORY ™V
ECU

Note: Install the MSDView software before connecting
the MSD product.

1. Insert the MSD CD into your PC. The software will I
automatically begin the installation feature. If the
“autorun” feature is disabled on your PC, go to:
Start and select Run, Select your CD Drive, and
click on the Setup .exe file. The MSDView wizard

will walk you through the setup.

FACTORY
HARNESS

If the .NET Framework is not installed on your PC,
the MSDView software will prompt the download and
setup. Click “Accept” to begin the update and follow
the steps. (This requires an internet connection).
Depending on Internet speed, it may take awhile to download and install .NET.

Figure 4 MSD ECU Wiring.

Found New Hardware Wizard

FIRST TIME CONNECTION
1. Connect the MSD to the PC with the supplied USB cable.

Welcome to the Found New
Hardware Wizard

This wizard helps you install software for:

Note: The first time the MSD is connected to your PC it will
perform a new hardware installation (Figure 5).

Commurications Part

() 1If your hardware came with an installation CD
“ZE2 or floppy disk. insert it now.

2. The Wizard will detect the Com Port and install the required
files. This may take a few minutes.

w'hat do pou want the wizard to da?

(@) Install the software automatically (Recommended]

() Install from a list or specific location [Advanced)
3. The Hardware installation window will stop the setup to ik Next o cortinue.
alert you about the installation. Click “Continue Anyway”
and the “Finish” to complete the installation .
Figure 5 Hardware Wizard.
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INSTALLATION INSTRUCTIONS 3

MSDVIEW SCREEN

When the MSDView software is run, a “Connect” screen
will show all MSD products the software will work with.
Select PN 4247 and click connect (Figure 6). If there
is a communication issue with the MSD, refer to the
“Communication Troubleshooting’ Guide.

Connect to MSD

Part Nurnber / Serial Mumber / COM Part

TUNING TABS
The 10-position rotary dial allows you to select from 10
preset tunes (Figure 7).

Select the desired TUNE tab to view or modify the [ Comect Jf Reresn o  Cacd |
corresponding TUNE. s\ /: .

Note: The rotary dial will select the TUNE that controls
tab is green.

» Monitar
[ SETTINGS | ADVANCE [FUEL || FUEL ACCEL | NOTES| | Hame Units

TUNEQ: ADVANCE: (Read Onlv) 0 ke efected

WEHICLE SPEED MPH
ENGINE SPEED O RPM

4 ENGIME SPEED RPM
1000 | 2000 3000 4000 5000 6000 | 7000 | 8000

GREEN HEADING o
SHOWS WHICH S e VIONITOR

deTDC

TUNE IS ACTIVE IN S B wiemr  [TEMS v
COOLAMT TEMPERATURE 167  DEGF
0
THE CONTROLLER. = TIMING ADVAMCE 00 DEGREES
F‘ FUEL DUTY 0%
INTAKE AR TEMPERATURE 130 DEGF
FUEL ACCEL GAIN [

AB

o

o

MAP 5.1 PSIA

v
GREEN BALL SHOWS
REAL TIME VIEW OF
ENGINE PERFORMANCE.

| MSD View Screen

COM1 COM46 Connected 4247 YFZ Sn6S COM46 4247 YFZ25n 65

Figure 7 MSDView Window.
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() INSTALLATION INSTRUCTIONS

SETTINGS TAB
Engine Speed Limit: Allows the user to set the
maximum engine speed. Adjustable from 2,000 RPM

Function

Engine Speed Limit 10500  RPM
Wehicle Speed Limit 93 MPH

Value [nitg

to 13,000 RPM. Decel Fuel Cutoff 13000

Vehicle Speed Limit: Allows the user to set the Figure 8 Settings Tah.

maximum vehicle speed. Adjustable from 12 mph ENGINE SPEED 0 RPM

to 124 mph 1000 = 2000 3000 4000 S000 G000 7000 8OO0 @ 9000 | 10000
14.5 a a a a a a a a a 1}

Decal Fuel Cutoff: Allows the user to program an B1 0 (o |0 |0 o |0 o |0 0|0

rom at which fuel will be cut off only during closed 16 o oo oo o oo |0o]o

throttle. Set Decal Fuel cutoff from 4,000 to 13,000 £l w02 o |olo|o|o|olo]o]|o]a

rpm. = 87 o | o o |o o |o|o|o |0 |60

ADVANCE TAB % 73 1] 1] 1] 1] 1] 1] 1] 1] 1] 1}

Note: The 0 setting in the programming tables is equal I I I T

to factory settings. st L L R L R IR R R M

28 a a a a a a a a a 1}

The Advance table controls the amount of ignition l§ [» s o [ o [ o | o n o [ o oo o

timing advance to be added to OEM timing. w

The custom tune is made by editing the cells in the
MAP vs Engine Speed table.

GREEN BALL INDICATES THE REAL
TIME ENGINE PARAMETERS.

Figure 9 Advance Table.

Cell values range from -30° to 30° over factory settings.

The green ball provides a real time view of the engine
speed vs MAP (Figure 9).

FUEL TAB
Note: The 0 setting in the programming tables is equal
to factory settings.

The Fuel table controls the injector pulse width by
editing the cells in the TPS % vs. Engine Speed table.
Cell values range from -50% to 80% (Figure 10).

FUEL ACCEL TAB

ENGINE SPEED D RPM

1000 2000 @ 3000 @ 4000 @ S000 @ 6000 | 7OOO | BOOO | SO00 @ 10000

Figure 10 Fuel Table.

TUNE4: FUEL ACCEL:

Allows the user to plot fuel gains from 0 to 100% vs
engine speed. (This function is similar to adjusting the
acceleration pump on a carbureted engine.) It allows
for additional fuel to be added during rapid throttle
position changes to help throttle response reaction
and performance.

ENGINE SPEED

Trace Edit | View

FueldccslGan (&)

1460

Color

FUELACCEL
GAIN

72

FUEL ACCEL GAIN vs ENGINE SPEED

FLEL ACCEL GAIN %

4400

04

850

15

0 1000 2000 3000 4000 5000 EOOQ OO 8OO0 9000 10000

ENGINE SPEED RPM

Figure 11 Fuel Accel Tahle.
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INSTALLATION INSTRUCTIONS

NOTE TAB
Notes can be entered for each Tune under the Notes Tab.

MONITOR

The Monitor Tab displays item readings in real time (Figure 11).

Tune: Rotary dial position and active TUNE.

Vehicle Speed in MPH or KPH.

Engine Speed in RPM.

MAP: Manifold Absolute Pressure in PSIA or KPA.
TPS: Throttle position displayed in percentage.
Engine Timing in degrees BTDC

Battery Voltage in volts.

Coolant Temperature in °C or °F.

Timing Advance: Change to OE ignition timing in degrees.
Barometric Pressure in PSI.

Coil On: Measurement of coil on time in milliseconds.
Intake Air Temperature in °C or °F.

Fuel Accel Gain in percentage.

Mame

TUME

WEHICLE SPEED
EMGINE SPEED
AP

TPS

EMGINE TIMING
BATTERY

COOLANT TEMPERAT...

TIMING ADVAMNCE
FUEL DUTY

INTAKE &IR TEMPERA...

FUEL ACCEL GAIM

A B 2w

Walue| Units
0  Selected
0 MPH
0 RPM
51  PSlA
(I 4
00 deTDC
00 WOLTS
1.. DEGF
00 DEGREES
(L4
1.. DEGF
o x

Figure 12 Monitor ltems.

All Monitor items can also be viewed as a gauge by selecting the gauge tab.

FACTORY PRESET TUNES

The Blaster FI Controller has four locked calibrations. The remaining six positions (4-9) are for

calibrations that can be modified through a PC with the MSDView software.

The following are brief descriptions of each calibration.

0 - Stock (Locked)

1 - Enhanced Stock (Locked)

2 - Pipe and Air Filter(Locked)

3 - Pipe and Air Filter plus 500 RPM - (Locked)
4 - Stock Enhanced

5 - Stock Enhanced

6 - Stock Enhanced

7 - Stock Enhanced, default (Same as Tune 2, User configurable)
8 - Stock Enhanced, default (Same as Tune 2, User configurable)

9 - By-pass (Diagnostic) - (Locked)
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6 INSTALLATION INSTRUCTIONS

TABLE EDITING
To update cells in the Advance or Fuel tables,
highlight one or more cells, type the new value and
hit enter (Figure 13).

ENGINE SPEED  RPM
0 | 1000 = 2000 @ 3000 4000 @ SOO0 @ GOOOD @ 7000 @ 8000 @ 9000

Note: In the table, 0 is equal to the factory setting.

MAP PSIA,

Right-clicking the highlighted cells will give the
option to offset, scale, or to copy the highlighted
cells (Figure 14).

Offset: Increments the selected cells value by the
new value.

For example, if the value in the selected cell is 2,
offsetting by 1 will change the cell to 3 (2+1=3).

Figure 13 Select Cells.

Scale: This option will multiply selected cells by the

value entered. ENGINE SPEED  RPM

0 1000 | 2000 @ 3000 @ 4000 S000 @ 6OOO @ 7000 @ 8000 @ S000

Note: Cell values will be clamped to their minimum 5 ‘ 0 ‘ 0 ‘ 0 ‘ 0 ‘ 0 ‘ pjojo
or maximum range default if the Offset or Scale
output values exceed the cell range.

Copy: Values can be copied and pasted into other
Tune tables.

MSDVIEW SOFTWARE TIPS AND HINTS
UNITS (Metric/English)

To toggle between English and metric units select
“View > Units’, then make a selection.

SAVING AND OPENING FILES

MSDView can save files with all settings on the local
drive. These files can be viewed, edited, emailed or transferred to a different controller at a later time. To
save all current settings, select ‘File > Save As...’, type in the new file name and press ‘Save’. To view, edit
or transfer settings to a different controller select ‘File >Open’.

Figure 14 Edit Options.

RESTORING DEFAULT VALUES
To restore all values select ‘Edit>Default’. Restoring default values will overwrite all settings in the controller
to their original default values.

TEXT SIZES
A range of text sizes from ‘Largest’ to ‘Smallest’ can be chosen by selecting ‘View>Text Size’ from the
menu bar.
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INSTALLATION INSTRUCTIONS 7

COMMUNICATION TROUBLESHOOTING
If there is no communication between MSDView and the MSD, use the following steps to check the
communication ports.

Note: MSDView needs to be installed and closed at this point.

1. Connect the MSD to the PC.

2. Open the Device Manager by clicking on: Start > Run > Type ‘devmgmt.msc’ (In Windows 7 type it
into the search box).

3. In the Device Manager window: Locate the ‘MSD Virtual COM Port’ with a yellow alert under the ‘Ports’
or ‘Other Devices'’ listing.

4. Right click and select ‘Update Driver’.

5. If necessary, click ‘Continue Anyway’ to complete the driver installation.

6. Open MSDView and connect to the MSD.

MSD POWERSPORTS - wWww.MSDPOWERSPORTS.COM - (915) 858-3365 - FAX (915) 858-3496



MSD

POWER
SPORTS

TECH NOTES

Service

In case of malfunction, this MSD component will be repaired free of charge according to the terms of the warranty.
When returning MSD components for warranty service, Proof of Purchase must be supplied for verification. After
the warranty period has expired, repair service is based on a minimum and maximum fee.

All returns must have a Return Material Authorization (RMA) number issued to them before
being returned. To obtain an RMA number please contact MSD Customer Service at 1 (888) MSD-7859 or visit
our website at www.msdperformance.com/rma to automatically obtain a number and shipping information.

When returning the unit for repair, leave all wires at the length in which you have them installed. Be sure to include
adetailed account of any problems experienced, and what components and accessories are installed on the vehicle.
The repaired unit will be returned as soon as possible using Ground shipping methods (ground shipping is covered
by warranty). For more information, call MSD at (915) 855-7123. MSD technicians are available from 7:00 a.m. to
5:00 p.m. Monday - Friday (mountain time).

Limited Warranty

MSD warrants this product to be free from defects in material and workmanship under its intended normal use*,
when properly installed and purchased from an authorized MSD dealer, for a period of one year from the date of
the original purchase. This warranty is void for any products purchased through auction websites. If found to be
defective as mentioned above, it will be repaired or replaced at the option of MSD. Any item that is covered under
this warranty will be returned free of charge using Ground shipping methods.

This shall constitute the sole remedy of the purchaser and the sole liability of MSD. To the extent permitted by
law, the foregoing is exclusive and in lieu of all other warranties or representation whether expressed or implied,
including any implied warranty of merchantability or fitness. In no event shall MSD or its suppliers be liable for special
or consequential damages.

*Intended normal use means that this item is being used as was originally intended and for the original application
as sold by MSD. Any modifications to this item or if it is used on an application other than what MSD markets the
product, the warranty will be void. It is the sole responsibility of the customer to determine that this item will work for
the application they are intending. MSD will accept no liability for custom applications.
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